Can't Open Photos Using "Edit with" in Mac Photos

Talk about Pixelmator Pro, share tips & tricks, tutorials, and other resources.
User avatar

2019-06-19 22:32:48

Every time I try to use "Edit with..." to open a photo I'm viewing in Mac Photos I get a pop-up error message:

"The application “Pixelmator” cannot open the specified document or URL."

Any idea how I can fix that?

User avatar

2019-06-20 06:33:38

That sounds, to me, potentially like a one-time glitch, so have you tried simply restarting your Mac? That tends to help quite a lot in cases like this. Otherwise, we'd love to hear from you at for some more in-depth assistance!
User avatar

2019-11-15 15:47:06

Hello, I'm having trouble editing a photo directly from my photos app in Pixelmator. I restarted my mac as suggested but I still receive the same error: Image

Unable to make resource locally available: <PLInternalResource: 0x7f81cc002ef0> {
assetUUID: 365B0654-DB6C-4039-8546-1B51C19A16D2
objectID: 0x9df4c4b245703f21 <x-coredata://0806F944-B901-4086-935A-D484C7E06CB1/InternalResource/p3932>
resourceType: img-prim
version: org
dataStore: Primary (0)
dataStoreSubtype: Original (1)
dataLength: 3076197
fileID: -1
localAvailability: none
localAvailabilityTarget: neutral
remoteAvailability: unavailable
remoteAvailabilityTarget: available
isDerivative: NO
unorientedWidth: 5456
unorientedHeight: 3632
orientation: 1
qualitySortValue: 2147418122
fingerprint: AdU+aTR1Q5GzNv9qmIsXNaGeF4+p
uniformTypeIdentifier: public.jpeg
codec: (null)
sidecarIndex: 0
ptpTrashedState: untrashed
cplType: Original

Any ideas? Thanks!
User avatar

2019-11-15 16:20:29

That looks like it might actually be an issue with the Photos app rather than Pixelmator Pro. Do you have any other external editors that you could try and open the image in to confirm?