New from Photos... is slow or broken

Is something not working like it should? Let us know.
User avatar

2017-12-02 15:39:27

If you find that the photos import seems slow or broken, be sure to quit Pixelmator and open Pages or another app and check that inserting a Photo works from that app.


I think my iCloud photo library either is churning through lots of updates or is broken since it's not working from multiple apps. I wanted to post here in case others see it since my first inclination was to think the new Pixelmator Pro app was buggy.


Another quick way to test this would be to make a new user account, fire up Photos to make a simple / blank library and then check the apps in that new account. If someone has a better health check to see what's making the gear grind for hours and no results to show in the photos picker, I'm open to suggestions, but I'll take that up with Apple directly.
User avatar

2017-12-10 06:27:54

In Pages adding image works fine. With Pixelmator Pro 1.02. it showed me images, but I could not open them. At Pixelmator Pro 1.04. it does not even show me my Photos images.

Pixelmatro Pro is not even alpha software, it is an Unusable mess. But I like the interface and I liked the Pixelmator (the old one) against for example Affinity. Hope this will get usable at some point...
User avatar

2017-12-15 15:02:39

This is happening to me too. When I first select 'New from Photos', it displays photos...with the oldest at the top. That's problem number 1. Put the newest at the top!

If I select anything else (Moments, a particular year, etc.) it just spins. I've waited for 5 minutes at most.

Also, while we're at it, please add the option to open a picture in Pixelmator from other applications, including Photos.

Good luck!
User avatar

2017-12-15 15:08:46

This appears to be resolved in the update that came out today (12/15/17). Woohoo!
User avatar

2017-12-17 21:49:53

This isn't resolved by the recent update for me. in earlier versions it would hang and require a force quit. Now I just get a spinning wheel when I choose "new from Photos" from the menubar. (BTW, I don't think that badmouthing the developer who is asking for feedback will help this).
User avatar

2017-12-23 12:15:00

by Arbus 2017-12-17 21:49:53 This isn't resolved by the recent update for me. in earlier versions it would hang and require a force quit. Now I just get a spinning wheel when I choose "new from Photos" from the menubar.
The same for me. (Pixelmator Pro 1.0.5, macOS 10.13.2)
by Arbus 2017-12-17 21:49:53 (BTW, I don't think that badmouthing the developer who is asking for feedback will help this).
Total agree.
User avatar

2018-12-19 14:09:48

I realize this is an old discussion but I'm having a similar problem. When I try to open 'New From Photos....', Pixelmator Pro 1.2.4 defaults to Photo Booth and reports No Photos Found. This is true because I have no photos in Photo Booth. I've been in contact with Support but they can't replicate the problem. On rare occasions my Photos Library will appear in Pixelmator but after a reboot, it defaults to Photo Booth again and then there's no indication of a Photos Library. Resetting Photos, will sometimes get Pixelmator to work but it's temporary until the next reboot. Just an FYI, I'm running Mojave 10.14.2