Version 2.0.4 Unable to update

Is something not working like it should? Let us know.
User avatar

2021-02-01 21:40:57


When I try to update to version 2.0.4 on the App Store, I receive a message titled "Unable to Download App" with a message below, "'Pixelmator Pro' could not be installed. Please try again later." I have received this message for other apps on occasion but usually after one or two more tries it works. I have tried many times each day since the update was released a few days ago, have signed out of the App Store, restarted my computer, and signed back in, still no luck. Any tips on what might be the problem!?
User avatar

2021-02-01 21:51:40

Have you tried removing the app? Just move it to the trash, then go back to the App Store to download it. If that fails you can still get it back from the trash to resume using the older version and try again another day. This has worked for many things for me in the past.
User avatar

2021-02-02 17:40:46

Yep, mccoytest is right — reinstall usually does the trick. Signing out of the App Store and signing back in is also a thing you could try.