Brush softness stuck at 0, greyed out.

Is something not working like it should? Let us know.
User avatar

2018-01-24 15:59:29

Is this a bug? I've spent 45 minutes trying to figure out some way to ungrey out the softness option, I can't paint on anything.
User avatar

2018-01-24 17:11:47

Sorry to hear you are having trouble with the brush tool. I can however not replicate your issue. Could you describe in steps what you are doing and / or post a screenshot of your Pixelmator window with the brush tool active? That way we can maybe help you better.
User avatar

2018-01-26 07:00:08

by Sebastiaan 2018-01-24 17:12:48 Sorry to hear you are having trouble with the brush tool. I can however not replicate your issue. Could you describe in steps what you are doing and / or post a screenshot of your Pixelmator window with the brush tool active? That way we can maybe help you better.
Hey Sebastiaan,

Is it true that many of the brushes do not allow a softness setting? For instance, the softness on all the stock pencil brushes cannot be changed.
User avatar

2018-01-29 15:53:06

You are correct I didn't look far enough. Only the softness of the basic brushes can be adjusted. Indeed a bug.
User avatar

2019-02-03 20:45:58

Hello,
It's a year later and this bug is still present. I'm using the free trial for the first time, and I like the app, but I'm suspicious of no updates in a year.
User avatar

2019-02-04 15:36:48

by Xiolanthe Hello,
It's a year later and this bug is still present. I'm using the free trial for the first time, and I like the app, but I'm suspicious of no updates in a year.
Hey there, Sebastiaan was actually a little too quick to write this off as a bug — it isn't. Softness can be changed for the basic brushes only and this behavior is exactly the same in the original Pixelmator as well. Any texture-based brushes essentially have the Softness "baked in", that particular option was simply less visible as it was only in the Brushes palette. I guess having it in the Tool Options pane makes it seem like a potential bug.
User avatar

2019-02-04 16:48:36

I still consider it a bug. A softness of 0 would a opacity of of 0 for the pattern and softness of 100 would opacity of 100 for the pattern. Or perhaps a softness of 0 represent the pattern as is and as the softness increased, so would the blur of the pattern. That can not be accomplished with a "baked in" softness. I know I'm fighting battle, here, but just because that’s the way it was in the orginal Pixelmator still doesn’t make most beneficial and flexible for the users..
User avatar

2019-02-05 10:02:48

That I can agree with — for now, you could do this manually by double-clicking the brush to edit it, dragging out the Shape texture into the Layer list, applying a Focus blur to it, then dragging the layer back into the Shape texture image well and inverting it. That's a bit of a long-winded process and I think we could add this setting to the Brush tool in some way for both textures, but it's a feature request more than a bug, so I just wanted to clear that up.