hangs and crashes after updating to Pixelmator Pro 1.3

Talk about Pixelmator Pro, share tips & tricks, tutorials, and other resources.
User avatar

2019-01-24 10:32:10

Hi!

After updating Pixelmator Pro to 1.3 via App Store, the app isn't running as smooth as before!
After clicking on Pixelmator Pro symbol to start the app my new Apple MacBook Pro (13-inch, 2018, Four Thunderbolt 3 Ports, 2,7 GHz Intel Core i7, 16 GB 2133 MHz LPDDR3, Intel Iris Plus Graphics 655 1536 MB) with latest macOS Mojave 10.14.3 (18D42) installed is hanging about 20-30 seconds. In this time I cannot do anything (sometimes I can move the mouse very slowly). After this time Pixelmator Pro opens and I can do my picture works (only cropping jpgs with about 5-8 layers!). Using built-in effects (zoom, blur, etc.) in the latest update Pixelmator Pro is crashing and I have to force quit the app. After quitting Pixelmator Pro my system is running fast again (normal state!).

I already trashed Pixelmator Pro and reinstalled the latest version via Mac App Store. But with the same results.
Is it possible to get version 1.2.4 again??? this version runs soooooo great on my MacBook Pro!

Best,
Marcus
User avatar

2019-01-24 10:37:54

Hi Marcus, it seems like you may have stumbled upon a bug of some kind – if you haven't done so already, could you email us at support@pixelmator.com? We'll obviously do our best to fix this and, in the meantime, we can also share the previous version of the app with you too.
User avatar

2019-01-24 10:39:07

by Andrius 2019-01-24 00:00:00 Hi Marcus, it seems like you may have stumbled upon a bug of some kind – if you haven't done so already, could you email us at <a href="mailto:support@pixelmator.com">support@pixelmator.com</a>? We'll obviously do our best to fix this and, in the meantime, we can also share the previous version of the app with you too.
already sent a support request!
Thanks!